2010 A/C Compressor won't kick on - Nissan Murano Forum
User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 7 Old 07-21-2015, 10:47 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2010 A/C Compressor won't kick on

So first the background.. We bought our 2010 murano SL in 2013 with 38k miles, it now has 73k. We haven't had a single problem with it until now.

On a recent road trip, in the blazing Texas heat, our a/c started blowing hot. So a few miles down the road we stop and I pop the hood, and see the compressor isn't running, so I figured it may just be low on freon. When I got home I put some gauges on it and had a can of freon to put in it, but when hooking up the gauges I saw it had tons of pressure in the system (I don't recall the actual reading, but it was high, higher than it probably should be?). So the system definitely isn't low on freon, maybe its too high and I need to bleed some off??

Anyways, I figured I will start troubleshooting the compressor. I checked the fuse, since that's the easiest.. But it was good. Is there a relay somewhere? Next I was going to check the pressure switch, which I located (on the top side of the compressor) but haven't gotten to yet. I just haven't had the time. But I want to make sure it is good, and then jump the compressor to see if I can get the clutch to engage. If it doesn't, I guess I have a bad compressor...

Am I on the right track? I have a lot of experience working on vehicles, but not so much with newer, imported vehicles. I have searched and searched but haven't turned up much so i am assuming this isn't a real common problem with these models or maybe people with muranos just take them straight to a dealership or shop? (That's not my style.. I prefer to do the work myself to save a little money..) Should I be looking at something specific or do the compressors just fail on the vehicles? Could it be some sort of other electrical problem? Are these compressors or systems similar to the older year models or other Nissans? Is there a diagram for the a/c system?

Thanks in advance and i really appreciate any help!
lpcharger is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-21-2015, 06:29 PM
Moderator
 
zebelkhan's Avatar
 
Join Date: Aug 2004
Location: Morgan Hill, Ca
Posts: 7,280
Mentioned: 5 Post(s)
Tagged: 2 Thread(s)
Quoted: 131 Post(s)
You are on the right track, except I would have checked the fuse, then the clutch, and then the freon, in that order.

If the fuse is good, then my bet is on the clutch being bad. There are sticky's in the maintenance forum addressing issues like that.

Former owner of 2004 SL AWD
zebelkhan is offline  
post #3 of 7 Old 08-04-2015, 07:05 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by zebelkhan View Post
You are on the right track, except I would have checked the fuse, then the clutch, and then the freon, in that order.

If the fuse is good, then my bet is on the clutch being bad. There are sticky's in the maintenance forum addressing issues like that.
Well last night I verified there is power at the plug on the compressor, and I checked the reference voltage (5v) on the pressure sensor (I wasn't comfortable messing with the sensor because I didn't want to fry the computer). Can someone confirm the wire colors? I know the pink is the ref voltage, is the blue the ground and the black the signal?

Tonight I will try to jump the clutch coil from the battery to see if it pulls in. If it doesn't I will replace the clutch, if it does, I will replace the sensor.

So there are no common or known issues with these systems? I just find it very odd and frustrating that I am having problems with it so early...

And can someone confirm that there is no relay for the a/c? I am not used to there not being a relay so I just want to double check...

Thanks in advance!
lpcharger is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 08-05-2015, 05:13 PM
Moderator
 
zebelkhan's Avatar
 
Join Date: Aug 2004
Location: Morgan Hill, Ca
Posts: 7,280
Mentioned: 5 Post(s)
Tagged: 2 Thread(s)
Quoted: 131 Post(s)
I am sure there is a relay. Do you have access to the service manual? There are many links on this forum to online pdf files. The electrical section of the service manual should have the location of the relay. But if you have power at the plug then relay is probably working.

Former owner of 2004 SL AWD
zebelkhan is offline  
post #5 of 7 Old 08-06-2015, 04:45 PM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by zebelkhan View Post
I am sure there is a relay. Do you have access to the service manual? There are many links on this forum to online pdf files. The electrical section of the service manual should have the location of the relay. But if you have power at the plug then relay is probably working.
Yeah if there is one I would agree that it is working because I get power at the plug when I have the a/c on and no power when it if off.

I wired up the clutch to the battery and the dang thing didn't budge, I also got an open loop on the meter when checking resistance through the coil.. so I will be replacing the clutch.

I think I am going to order this one on ebay. Kind of weird that no parts house sells just the clutch? Or at least that I could see online..
AC Compressor Clutch Coil Fits Nissan Murano 2011 2012 A C Magnet | eBay
lpcharger is offline  
post #6 of 7 Old 08-11-2015, 09:03 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
FYI, the clutch coil from eBay came in, I swapped it out and everything works.

$58 bucks and didn't have to touch the refrigerant, can't beat that type of a/c repair!

Cold A/C for the wife!
lpcharger is offline  
post #7 of 7 Old 08-11-2015, 01:40 PM
Super Moderator
 
Pilgrim's Avatar
 
Join Date: Dec 2009
Location: Fort Collins, CO
Posts: 6,604
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 421 Post(s)
Hoo wah!!

2008 BMW E91 328xi Sportwagon
2009 BMW E92 328ix Coupe
2000 Jeep Grand Cherokee
1983 280ZX Turbo
Pilgrim is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On