1st Gen (2003-2007) - Nissan Murano Forum
Post New Thread
Threads in Forum : 1st Gen (2003-2007) Forum Tools Search this Forum
  Rating Thread / Thread Starter Last Post Reverse Sort Order Replies Views
 
3 Attachment(s) Sticky Thread Sticky: Front Lower Ball Joint Replacement (Multi-page thread 1 2 3 ... Last Page)
The compressor and power tools or
07-31-2016 08:39 PM
by nafddur Last Post
89 72,113
 
13 Attachment(s) Sticky Thread Sticky: DIY: Power Steering High Pressure line repair (Multi-page thread 1 2 3 ... Last Page)
THanks for the link, its very helpfull
07-30-2016 09:18 AM
by jankoluvsky Last Post
119 99,086
 
30 Attachment(s) Sticky Thread Sticky: How To -- High Pressure Power Steering Hose (Multi-page thread 1 2 3 ... Last Page)
I replaced the high pressure hose on my
07-07-2016 10:27 PM
by gratefullrolf Last Post
83 32,506
 
Sticky Thread Sticky: HOW-TO: Fix rusted/sticking hatch levers! (Multi-page thread 1 2)
That is an awesome post, you did a
05-22-2016 01:29 PM
by 2007se Last Post
24 9,191
Talking
23 Attachment(s) Sticky Thread Sticky: OEM Navigation Added to 2004 SL (Multi-page thread 1 2 3 ... Last Page)
If you are using the Magellan 1700 to
04-29-2016 05:45 PM
by ekaxel Last Post
110 48,128
 
I do almost all my own repairs, but my
07-13-2015 09:57 PM
by DreamCar5683 Last Post
10 18,076
Post
15 Attachment(s) Sticky Thread Sticky: Want Colder AC? Here's How To Do It! (Multi-page thread 1 2 3 ... Last Page)
has anyone ever wondered why the A/C
06-09-2015 09:22 PM
by john 07 Last Post
113 49,807
 
Question
Your terminology is incorrect. You are
Yesterday 07:48 PM
by Pilgrim Last Post
2 172
 
me too!! bloody doing my head in, ive
02-25-2017 09:28 AM
by Miike Last Post
6 713
Unhappy
Or you can put it into Photobucket and
02-24-2017 01:39 AM
by srT4URBO Last Post
8 120
 
YW, Juan. I'm surprised others here
02-22-2017 10:12 PM
by nafddur Last Post
14 283
 
Reviving this tread. I did the same as
02-20-2017 08:25 PM
by jljonsn1 Last Post
6 2,342
 
I cannot see the pics.
02-20-2017 01:54 PM
by srT4URBO Last Post
3 79
 
I have the same problem, but I have not
02-20-2017 11:40 AM
by rmolinger Last Post
1 434
 
I don't remember the part number but
02-20-2017 02:20 AM
by srT4URBO Last Post
17 15,117
 
Has anyone removed the rear springs
02-19-2017 02:10 AM
by srT4URBO Last Post
3 145
 
A door lock actuator is the component
02-18-2017 03:46 AM
by Deanjones Last Post
3 1,638
Angry
Have 2007 Murano, had a bad radiator,
02-16-2017 03:12 PM
by MustangJim1 Last Post
0 60
 
My CVT was replaced under warranty at
02-16-2017 02:42 PM
by MustangJim1 Last Post
6 449
 
catalytic converter work (Multi-page thread 1 2)
In case anyone is reading this looking
02-16-2017 04:32 AM
by Hugh Jass Koda Last Post
18 16,703
 
Yes, you'd be amazed how often it's
02-15-2017 03:11 PM
by Pilgrim Last Post
2 90
 
P0345 Hard start VDC light issues (Multi-page thread 1 2)
Just to refresh the problem - I have
02-14-2017 08:38 AM
by SLOpoke Last Post
15 401
 
Hi my MO 06 I switch the alternator and
02-13-2017 05:55 PM
by jimperez Last Post
0 79
 
That's what mine was doing and there
02-10-2017 12:55 PM
by Halwg Last Post
5 180
Unhappy
There is a way to turn it on and off
02-07-2017 04:15 PM
by Mick07060 Last Post
3 679
 
I didn't have a bad coil. Coils were
02-07-2017 02:58 PM
by MO04 Last Post
14 631
 
We might have the same issue, I'm
02-07-2017 02:53 PM
by MO04 Last Post
1 119
 
Depends where you go. Same exact thing
02-04-2017 04:32 PM
by srT4URBO Last Post
1 119
 
Hello all, I have read the how to on
02-01-2017 07:38 PM
by Stephen Casey Last Post
0 113
 
The car is an AWD. I have replaced the
01-31-2017 01:47 PM
by sleimannissan Last Post
3 197
 
Thanks guys. I checked the part numbers
01-27-2017 03:36 AM
by jonathanp Last Post
4 153
 
The good news is that even when it
01-25-2017 06:02 PM
by Pilgrim Last Post
5 321
 
If the alternator is out, then yes, it
01-24-2017 12:04 AM
by srT4URBO Last Post
3 247
 
Sorry are you saying that there is no
01-12-2017 03:21 PM
by GateKeper Last Post
3 206
 
Pics of plug. As you can see the top
01-12-2017 12:16 AM
by az240z Last Post
21 13,863
 
Just to be sure, when you say transfer
01-11-2017 10:51 PM
by MO04 Last Post
3 210
 
The jerking you ^^^ describe has been
01-09-2017 11:05 PM
by srT4URBO Last Post
6 322
 
I used OE NGKs for the plugs. I also
01-09-2017 09:38 AM
by srT4URBO Last Post
2 246
Exclamation
FYI, My 2014 Infinity QX60 drivers side
01-08-2017 07:53 PM
by Bob Innes Last Post
39 73,403
Unhappy
If the weather is really cold, it may
01-06-2017 08:51 PM
by Pilgrim Last Post
4 235
 
Oh my goodness... I just happened to
01-06-2017 03:22 PM
by oldAGE Last Post
1 229
 
Another option is to buy any standard
01-01-2017 04:40 PM
by deeman Last Post
2 238
 
I don't have a picture but I did
12-28-2016 03:21 AM
by srT4URBO Last Post
1 335
 
I put Monroe quick struts and have no
12-23-2016 11:29 PM
by MO04 Last Post
2 285
Question
Update: The car not starting was
12-21-2016 04:25 PM
by JennRal Last Post
4 488
 
Well I finally installed an aftermarket
12-21-2016 05:54 AM
by mcpaul Last Post
3 1,589
 
Does the engine cranks or not? Try
12-19-2016 10:36 PM
by MO04 Last Post
1 225
Post New Thread

Display Options Moderators
Showing threads 1 to 40 of 3662 Moderators : 5
 
Forum Tools Search this Forum
Mark This Forum Read
View Parent Forum
Search this Forum :

Advanced Search

New posts New posts More than 15 replies or 150 views Hot thread with new posts
No new posts No new posts No new posts Hot thread with no new posts
Closed Thread Thread is closed  

 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off