dash not working 06 murano - Nissan Murano Forum
User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 4 Old 05-07-2019, 01:30 PM Thread Starter
Registered User
 
Join Date: May 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
dash not working 06 murano

Hello all, I have a 06 Murano and I have a 150power inverter that plugs into the cig lighter. the part that plugs into the cig lighter broke so i got a new one and spliced it in with some clamps. My girlfriend went to go use it and took off all the electrical tape off it for some reason and the metal touched and shorted out my dash. the gas heat and speedometer and the rpm's gage and the lights in that cluster dont work. It also blew my alternator. I got a new alternator and installed it but either the car shorted the alternator again or my car is not getting power from the new alternator? I dont know what to do! anything would help!
KyleI is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-07-2019, 06:48 PM
Super Moderator
 
Pilgrim's Avatar
 
Join Date: Dec 2009
Location: Fort Collins, CO
Posts: 7,468
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 574 Post(s)
Check fuses. Normally when your dash doesn't light, it means your taillights are out too. They're all on the same fuse. Given what happened, I'd be very surprised if you don't have more than one fuse blown.

2008 BMW E91 328xi Sportwagon
2009 BMW E92 328ix Coupe
2016 Jeep Grand Cherokee Limited, 75th Anniv. Edition
1983 280ZX Turbo
Pilgrim is offline  
post #3 of 4 Old 05-09-2019, 05:25 PM Thread Starter
Registered User
 
Join Date: May 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
yeah i checked the fuses...nothing looks wrong...
KyleI is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 05-11-2019, 12:52 AM
Registered User
 
I need coffee's Avatar
 
Join Date: Oct 2018
Location: Midwest
Posts: 185
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Quote:
Originally Posted by KyleI View Post
yeah i checked the fuses...nothing looks wrong...
When you say you checked the fuses, did you also check those in the fusible link attached to the battery positive terminal?
I need coffee is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash board lights not working when headlights come on Scott Gagel 1st Gen (2003-2007) 1 12-24-2018 04:37 PM
Looking for Metra Dash and Android 6.0 for 06 MO Murano06USA 1st Gen (2003-2007) 1 05-02-2017 10:41 AM
06 Murano rattles and odd screech sound (Not shield, not gussets) *Video rt82 1st Gen (2003-2007) 2 07-08-2015 09:58 AM
2006 Murano - in dash display not changing background when headlights on oldAGE 1st Gen (2003-2007) 2 12-06-2011 12:30 PM
03 murano interior light not working nima-priya Problems 8 09-30-2005 11:26 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome