New to me 09 Murano and SES light already - Nissan Murano Forum
User Tag List

 2Likes
  • 1 Post By I need coffee
  • 1 Post By Pilgrim
 
LinkBack Thread Tools Rate Thread
post #1 of 9 Old 06-13-2019, 10:10 AM Thread Starter
Registered User
 
Join Date: Jun 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
New to me 09 Murano and SES light already

Hello!

Just picked up our new (to us) 09 Murrano SL on Tuesday, and I have a SES code already. It's a P0507 which is a high idle.

Normally I'd just clean the throttle body, maybe change the idle air sensor, but I noticed something else that I want to ask about because I don't know if this is normal for Nissans.

The voltage to the dome light is fluctuating when the car is running, the light flutters depending on what's on. The AC fan makes it flicker nicely.

So I'm wondering if maybe I have an alternator problem causing my idle code. Is the flickering normal?

As a secondary question, should any Nissan dealership be able to tell me if or when the CVT was last serviced? I understand the CVT's require a little more attention than most transmissions.
Bill Brush is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 06-13-2019, 10:33 AM
Registered User
 
I need coffee's Avatar
 
Join Date: Oct 2018
Location: Midwest
Posts: 219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
Quote:
Originally Posted by Bill Brush View Post
Hello!

Just picked up our new (to us) 09 Murrano SL on Tuesday, and I have a SES code already. It's a P0507 which is a high idle.

Normally I'd just clean the throttle body, maybe change the idle air sensor, but I noticed something else that I want to ask about because I don't know if this is normal for Nissans.

The voltage to the dome light is fluctuating when the car is running, the light flutters depending on what's on. The AC fan makes it flicker nicely.

So I'm wondering if maybe I have an alternator problem causing my idle code. Is the flickering normal?

As a secondary question, should any Nissan dealership be able to tell me if or when the CVT was last serviced? I understand the CVT's require a little more attention than most transmissions.

Code description:

P0507: Idle speed control system RPM higher than expected

This code is set when the PCM detects that the idle is 200 RPMs or more higher than expected. Idle speed with no load (all accessories off) should be around 600 RPM (+/- 50). Does the idle seem abnormally high? If so, there is an idle relearn procedure you can do to reset it.

Otherwise, electrical problems could cause weird codes to pop up. How many miles on the car? Before looking at the alternator, check the condition of the drive belt to see if it's worn. You can also check the marks for the drive belt tensioner to see if they're out of spec causing the belt to be too loose.

You can find the aformentioned in the service manual, which you can download off the nicoclub website: https://nicoclub.com/FSM/Murano/2009/

Idle relearn procedure is in the Engine Control System (EC.pdf) file and the drive belt inspection instructions are in the Maintenance (MA.pdf) file. If you decide to troubleshoot the alternator, you can find information and wiring diagrams etc in the Charging System (CHG.pdf) file.

On your last question, a dealership probably won't be able to tell you much except look up the CVT fluid deterioration value, which is a proxy for the condition of the fluid. You can also download the CVTz50 app if you have an android phone and compatible OBDII wireless interface and look it up yourself as well as do other diagnostics. You can search these forums (esp. the 3rd generation) for more information on that app. Making CVT fluid changes a regular maintenance item is not a bad idea.

Good luck and let us know if/how you resolve the problem.
jorgedurand likes this.
I need coffee is offline  
post #3 of 9 Old 06-13-2019, 11:23 AM Thread Starter
Registered User
 
Join Date: Jun 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
My code reader was showing the idle at about 900-1000 last night, so a touch high.

The car has 105K miles on it, so not horrible, but low.

Thanks for the manual link, I'm going to download them all.
Bill Brush is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 06-13-2019, 11:38 AM
Super Moderator
 
Pilgrim's Avatar
 
Join Date: Dec 2009
Location: Fort Collins, CO
Posts: 7,490
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 578 Post(s)
Agreed, check belts and make sure all are OK.

If you want to check voltage, use a multimeter from battery + to - terminal and read DC voltaeg. WIth the car off the battery should be above 12V, usually @12.4V.

When it's running, right after you start it should be charging slightly over 14V, probably around 14.4V. That voltage may drop after it has run for a while and the battery is charged back up - the car is smart enough to reduce charging voltage as need dictates. I don't believe it should ever drop below 13.5V. Just to pick a number, if it's under 13V with the car running you definitely have an alternator problem.
MuranoSL2003 likes this.

2008 BMW E91 328xi Sportwagon
2009 BMW E92 328ix Coupe
2016 Jeep Grand Cherokee Limited, 75th Anniv. Edition
1983 280ZX Turbo
Pilgrim is offline  
post #5 of 9 Old 06-13-2019, 02:50 PM Thread Starter
Registered User
 
Join Date: Jun 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Ok dumb question, but the directions in the service manual refer to "turning ignition on" and "off" but it's got push button start, so how do I do that correctly? This is the first car I've ever owned that doesn't have a key.
Bill Brush is offline  
post #6 of 9 Old 06-13-2019, 06:43 PM
Super Moderator
 
Pilgrim's Avatar
 
Join Date: Dec 2009
Location: Fort Collins, CO
Posts: 7,490
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 578 Post(s)
Quote:
Originally Posted by Bill Brush View Post
Ok dumb question, but the directions in the service manual refer to "turning ignition on" and "off" but it's got push button start, so how do I do that correctly? This is the first car I've ever owned that doesn't have a key.
Exercise executive privilege and ignore it. I assumed it was for a version built in another market.

Translations from Japanese are much better than they were 40 years ago, but stuff like this still gets missed.

2008 BMW E91 328xi Sportwagon
2009 BMW E92 328ix Coupe
2016 Jeep Grand Cherokee Limited, 75th Anniv. Edition
1983 280ZX Turbo
Pilgrim is offline  
post #7 of 9 Old 06-13-2019, 09:48 PM
Registered User
 
I need coffee's Avatar
 
Join Date: Oct 2018
Location: Midwest
Posts: 219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
Quote:
Originally Posted by Bill Brush View Post
Ok dumb question, but the directions in the service manual refer to "turning ignition on" and "off" but it's got push button start, so how do I do that correctly? This is the first car I've ever owned that doesn't have a key.
I personally don't care for the push button ignition, but to answer your question--pushing the button once puts the car in accessories mode (ACC) while pushing the button twice turns the ignition "on" but doesn't start the car unless you also have your foot on the brake at the same time. Around the push button, you should see the respective lamps for each position illuminate.

I'm curious if the relearning procedure is a pain with the push button set-up (...a key seems more straightforward). Let us know how it goes.

BTW...if you do decide to clean the throttle body then do that first or otherwise you'll have to do the idle relearn twice.
I need coffee is offline  
post #8 of 9 Old 06-18-2019, 02:52 PM
Registered User
 
Kand2010's Avatar
 
Join Date: Jan 2019
Location: USA
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
You may be able to find past service records through a CARFAX. We always check those out before purchasing a car. I think if the vehicle has been taken to a dealer for service, it is automatically recorded and available to CARFAX. I personally, enter my service records if I receive a non-dealer service. You can download the CARFAX app and keep track of your records. You can even take pictures of the bills/receipts!

2015 Murano SL FWD
Magnetic Black
Kand2010 is offline  
post #9 of 9 Old 07-04-2019, 09:22 PM Thread Starter
Registered User
 
Join Date: Jun 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
So just an update, I reset the trouble codes, and we've been driving it normally for 2-3 weeks and it hasn't kicked an idle code since, so I guess it's happy. Thanks for all your help!
Bill Brush is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome