Nissan Murano Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi everyone!
I recently bought an 09 Murano and haven’t had any issues until today.
I was parked outside waiting for my sister, heat blowing (it’s -30 out). I decided to change it so the heat was blowing towards me. Suddenly it made this strange almost squeal type noise. So I changed it back to defrost, then noticed it’s now making this crackling sound. Almost like static. Any ideas on what this could be? I currently don’t have the money to go to a shop.
 

·
Registered
Joined
·
1,875 Posts
It may be possible that some ice crystals or something else got drawn into the circulation fan...

Remove your cabin air filter and check the area around the ducts and fan housing.
 

·
Registered
2010 Mo' LE, CVT Auto, FWD
Joined
·
72 Posts
Had some ice on my doors and I noticed some ice crackling or something breaking as I turned my wheels. In TN we got a snow storm warning or something coming up, so I gotta get some more defrost spray and let it warm up lol.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Had some ice on my doors and I noticed some ice crackling or something breaking as I turned my wheels. In TN we got a snow storm warning or something coming up, so I gotta get some more defrost spray and let it warm up lol.
Mines definitely from the inside! I live in Canada and we’ve been in a deep freeze, but this just randomly started. I’m thinking maybe some dried up leaves are stuck in my cabin air filter. Going to change that tomorrow.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
It may be possible that some ice crystals or something else got drawn into the circulation fan...

Remove your cabin air filter and check the area around the ducts and fan housing.
I think there might be some dried up leaves stuck in my cabin filter! I’m going to change it out tomorrow. Hopefully it resolves this issue lol.
 

·
Registered
2010 Mo' LE, CVT Auto, FWD
Joined
·
72 Posts
I think there might be some dried up leaves stuck in my cabin filter! I’m going to change it out tomorrow. Hopefully it resolves this issue lol.
How did it go? Just curious. :)
 
1 - 6 of 6 Posts
Top