Nissan Murano Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I appreciate any assistance I can get. I came to Hawaii on a short contract and bought a 2009 Murano. The day I drove away with it the ses came on and I have been dinking with it since. I ran some seafoam through which is just my SOP when I get a new used vehicle. PO said he had the O2 sensors on one side changed out but he didn't remember which. I started to look it over and saw that the air intake hose had a hole big enough for my whole hand to fit in. I ordered a new one and and put it in and the light went out. I also put a new gas cap just for grins before the air intake and It didn't help.
The codes were for O2 sensors by the way. Also to note when I would fill the tank up the ses light would go out for about 50 miles or so. I used premium.
Fast forward a week and ses light was back on and codes for catalytic converter 420. hmmm. So I pulled the cover off the top of the engine today to check all the vacuum lines which I should have done originally but my work schedule gives me no time. All of the vacuum hoses going to and from the runner valves etc were in bad shape and the nipple on a unit on the right side of the engine (see diagram) is broken off. So I am not sure what this is called and it looks like it is a part of the whole manifold. The car runs great except that at low RPMs when accelerating slowly it feels like it misses a little. If I increase acceleration it stops. That and the SES light which doesn't go off now. I reset it at the parts store and it came back in 5 miles. I am currently trying to JB Weld for plastic the nipple back on and will change out all the hoses tomorrow but any advice/ experiences etc would be much appreciated. I am leaving the Island in 2 weeks as my contract is over and I can't sell my problems to someone else. Thanks in advance. Also what is the unit circled in the diagram and what does it do?
Jaw Automotive lighting Automotive design Motor vehicle Font

Jaw Automotive lighting Automotive design Motor vehicle Font
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks I need coffee. I couldn't find anything about the system on the internet. So this doesn't seem like something that would cause the Cat code but it seems like these things are so interconnected. I will post what happens when I get it back together. Any other things I should be checking? Thanks
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top