Nissan Murano Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey guys,

I'm new to the forum and I'm hoping I can get some help. I'm being plagued by the infamous P0420 code and I'm trying to avoid going to the mechanic if I can help it.

I have a 2010 Nissan Murano S AWD 6 Cylinders A 3.5L FI DOHC.

I'm not really seeing or feeling any loss of power but I feel like I can hear a hissing sound coming from the upper, rear, central region of the engine bay. I know that probably sounds confusing but here is a stock image I found to give a better idea of the location.
51153


I've taken that plastic cover off and spent many hours over the past two weeks trying to identify where the hiss is coming from using my eyes, ears and a cool little endoscope I got on eBay and I'm coming up empty. I am really thinking there is a vacuum leak somewhere but I'm drawing a blank. I could just be hearing normal engine noise but the optimist in me is hoping it is a vacuum leak because the P0420 code is just an absolute nightmare to diagnose.

So have any of you folks encountered something like this or have any suggestions. I am a novice when it comes to car repair but I do have basic experience.

Any help would be greatly appreciated :)
 

·
Registered
Joined
·
2,703 Posts
Exhaust manifold crack is known to happen to the first gen. I would check there.
P0420 can be remedied by installing those anti Fowler in your O2 sensor-downstream.
 

·
Registered
2011 Nissan Murano LE AWD
Joined
·
1,108 Posts
I've got the 2014 murano not sure if thats still 1st gen?
2014 is the 2nd generation. What do you mean by "the exact same problem"? Do you have both a "hissing sound" and the MIL illuminated with a P0420 code? Please describe what's going on with your car in detail as the more information you provide, the better the advice you'll receive.
 
1 - 6 of 6 Posts
Top