Nissan Murano Forum banner
121 - 140 of 159 Posts

·
Registered
Joined
·
9 Posts
Two more. The clip pulls down on these two to release. Treat all cables the same, with the notches at the ends locking into place.

If the clip is broken and won't hold in place, try this.

Cut the ends off a round tooth pick, leaving it just long enough to so that it has to be wedged into the area where the clip, when down, would press into the wire. Use a hot glue gun to keep anything from vibrating loose and hold everything in place.

Good luck.

Have a good day.
So I got to the white cable, but having trouble getting it off. Any suggestions?
 

Attachments

·
Super Moderator
Joined
·
1,435 Posts
You have to press the center white tab at the wire end firmly and pull away from the board. I think I used a plastic trim tool to help lift the end when pressing and pulling.

Have a good day.
 

·
Registered
Joined
·
9 Posts
You have to press the center white tab at the wire end firmly and pull away from the board. I think I used a plastic trim tool to help lift the end when pressing and pulling.

Have a good day.
Got it switched out. Hooked it up but now it says that my usb is not connected even though it is. My iPhone charges but on the screen it says no usb connected. Plus I don’t i see the CarPlay
 

·
Super Moderator
Joined
·
1,435 Posts
Did you install the 2018 and check to see if it was fully functional before swapping the screen and bezel?

If it was working, all you really needed to do was swap the logic board between the two radios. The logic board controls everything except SiriusXM and the SD card holder. Check Nav antenna connector.

At this point in time, I would disassemble and check to be sure all ribbon cables are properly connected.

If that isn't the issue, put everything back the way it was and check the 2018 radio in it's original configuration.

Good luck.

Have a good day.
 

·
Registered
Joined
·
9 Posts
Did you install the 2018 and check to see if it was fully functional before swapping the screen and bezel?

If it was working, all you really needed to do was swap the logic board between the two radios. The logic board controls everything except SiriusXM and the SD card holder. Check Nav antenna connector.

At this point in time, I would disassemble and check to be sure all ribbon cables are properly connected.

If that isn't the issue, put everything back the way it was and check the 2018 radio in it's original configuration.

Good luck.

Have a good day.
Works on the original configuration but once i put it back in the 2015 bezel, it gives me that same error. The only boards I'm changing out are the first two correct?
 

·
Super Moderator
Joined
·
1,435 Posts
The board with the 40 pin connector is the logic board. That's all you should need to change out.

Take that out of the 2018 and install in your radio. Should work.

Good luck.

Have a good day.
 

·
Registered
Joined
·
9 Posts
The board with the 40 pin connector is the logic board. That's all you should need to change out.

Take that out of the 2018 and install in your radio. Should work.

Good luck.

Have a good day.
After having to get another radio and make a few changes, I got it to work. Thanks PaulDay for your assistance.
 

·
Registered
Joined
·
3 Posts
I found this same part time and want to swap the unit out in my 2015 Platinum. Did you have to have the radio unlocked or flashed or anything like that or was it literally plug and play?
I just installed the 25915-UE1A in my 2015 Nissan Murano Platinum and it was a plug and play - perfect fit and function.
 

·
Registered
Joined
·
2 Posts
I am very excited by the promise of having ACP in my 16 platinum. AA would be a bonus. I am however completely confused by the model numbers and years months listed here. I understand 2017.5 have ACP but how do I know which ones are .5 and what model am I looking for? There are a few other model numbers listed here that appear to work and some have AA but again am not sure what I should be looking for that is confirmed to work.
 

·
Registered
Joined
·
44 Posts
Verify what model you are actually getting from the seller. The pictures on Ebay show a different model than the description. Pictures show 9UE0A vs 9UE1B
 

·
Registered
Joined
·
10 Posts
Verify what model you are actually getting from the seller. The pictures on Ebay show a different model than the description. Pictures show 9UE0A vs 9UE1B
Yeah, that is what I'm worried about. The seller lists a lot of different model numbers in the description, but it doesn't need to be exact, right?
 

·
Registered
Joined
·
44 Posts
Yeah, that is what I'm worried about. The seller lists a lot of different model numbers in the description, but it doesn't need to be exact, right?
It does matter if you currently have a 11 speaker bose system in your Murano. Only specific Model number will work with Bose or Without Bose
 

·
Registered
Joined
·
10 Posts
It does matter if you currently have a 11 speaker bose system in your Murano. Only specific Model number will work with Bose or Without Bose
The seller's description says it's for the Bose system and has Android Auto. As far as I know, the Around View Monitor works on any 3rd gen Murano stereo.
 

·
Registered
Joined
·
44 Posts
The seller's description says it's for the Bose system and has Android Auto. As far as I know, the Around View Monitor works on any 3rd gen Murano stereo.
I will try and find the table that has the radio model number that works for each system......
 
121 - 140 of 159 Posts
Top