Nissan Murano Forum banner
121 - 140 of 166 Posts

· Registered
Joined
·
9 Posts
Two more. The clip pulls down on these two to release. Treat all cables the same, with the notches at the ends locking into place.

If the clip is broken and won't hold in place, try this.

Cut the ends off a round tooth pick, leaving it just long enough to so that it has to be wedged into the area where the clip, when down, would press into the wire. Use a hot glue gun to keep anything from vibrating loose and hold everything in place.

Good luck.

Have a good day.
So I got to the white cable, but having trouble getting it off. Any suggestions?
 

Attachments

· Super Moderator
Joined
·
1,753 Posts
You have to press the center white tab at the wire end firmly and pull away from the board. I think I used a plastic trim tool to help lift the end when pressing and pulling.

Have a good day.
 

· Registered
Joined
·
9 Posts
You have to press the center white tab at the wire end firmly and pull away from the board. I think I used a plastic trim tool to help lift the end when pressing and pulling.

Have a good day.
Got it switched out. Hooked it up but now it says that my usb is not connected even though it is. My iPhone charges but on the screen it says no usb connected. Plus I don’t i see the CarPlay
 

· Super Moderator
Joined
·
1,753 Posts
Did you install the 2018 and check to see if it was fully functional before swapping the screen and bezel?

If it was working, all you really needed to do was swap the logic board between the two radios. The logic board controls everything except SiriusXM and the SD card holder. Check Nav antenna connector.

At this point in time, I would disassemble and check to be sure all ribbon cables are properly connected.

If that isn't the issue, put everything back the way it was and check the 2018 radio in it's original configuration.

Good luck.

Have a good day.
 

· Registered
Joined
·
9 Posts
Did you install the 2018 and check to see if it was fully functional before swapping the screen and bezel?

If it was working, all you really needed to do was swap the logic board between the two radios. The logic board controls everything except SiriusXM and the SD card holder. Check Nav antenna connector.

At this point in time, I would disassemble and check to be sure all ribbon cables are properly connected.

If that isn't the issue, put everything back the way it was and check the 2018 radio in it's original configuration.

Good luck.

Have a good day.
Works on the original configuration but once i put it back in the 2015 bezel, it gives me that same error. The only boards I'm changing out are the first two correct?
 

· Super Moderator
Joined
·
1,753 Posts
The board with the 40 pin connector is the logic board. That's all you should need to change out.

Take that out of the 2018 and install in your radio. Should work.

Good luck.

Have a good day.
 

· Registered
Joined
·
2 Posts
I am very excited by the promise of having ACP in my 16 platinum. AA would be a bonus. I am however completely confused by the model numbers and years months listed here. I understand 2017.5 have ACP but how do I know which ones are .5 and what model am I looking for? There are a few other model numbers listed here that appear to work and some have AA but again am not sure what I should be looking for that is confirmed to work.
 
121 - 140 of 166 Posts
Top