Nissan Murano Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Everyone. My apologies for the long thread but I have a unique issue with my radio/nav unit:



It will arbitrarily change and scroll presets in AM, FM and SXM modes, it will arbitrarily pause, skip forward and skip backward tracks and folders in USB and CD modes, and while the map is on screen it will arbitrarily bring up the purple crosshair and sometimes move the map. All of these arbitrary changes are visible on the screen and occur at random times - from 2 minutes to 40 minutes of initial power up. The screen is responding normally when I touch the on screen buttons in any of these modes. The vehicle does not need to be running or in motion for these occurrences. I brought it to one dealer and they used my communications radio as a scapegoat to get out of repairing it under warranty. How convenient! They made less than zero attempts to diagnose the problem and made less than zero attempts to communicate with me on how the communications radio was installed. No doubt I will be contacting Nissan Corporate on their handling of my vehicle but that is another discussion.



I tried disconnecting the battery one day for 15 minutes and 8 hours the next day and the radio did not lose its presets nor did the vehicle lose the clock. I removed the radio and checked it for possible cobwebs between the circuit boards but there were none. During that time, I hoped the memory would clear out and I can start with a "fresh" unit but it still remembered the clock and presets. I'm not sure where the volatile memory is being stored but I figured removing it from the dash and leaving it out for a couple of hours would have reset it since the battery disconnection did not clear it. The radio/nav unit did the aforementioned when connected the vehicle to a known good and independent power source. So at this point I am perplexed at what is happening. I see the radio is made by Clarion and there is already a replacement model. I have the 25915 9UA1C and according to the Nissan parts website, the replacement part is the 25915 9UA3A. Could this replacement be out because of the issues I have and some of the Bluetooth issues I've heard about? The label on the unit says it contains software by Microsoft. Perhaps software issues?? Can the dealers reflash the unit and/or the controller? If not, why??



I have another dealer willing to look at it and hopefully they can figure it out. I have removed my communications radio from the vehicle so they have no chance of using it as a scapegoat. In case you are wondering, the only connection the communications radio requires is a direct connection to the battery because it is a self-contained device and requires absolutely no interface to the vehicle controls or serial communication bus. I did not have any issues in my 2015 Murano SL AWD TECH which is equipped exactly as my 2017 Murano SL AWD TECH and it had the exact communications radio in it as well and wired in the same independent manner. Have any of you experienced this self-scrolling, track-changing, map moving issue(s)?
 

·
Registered
Joined
·
1 Posts
Same problem!!

I have a 2017 Platinum and just started having the same problems!! It’s driving me insane! ? I drop my car off Friday to see what’s going on. I’ll keep you posted!
 

·
Registered
Joined
·
1 Posts
I have 2017 SL. I went in a store and came out. The control panel touch screen as well as the buttons along the sides are unresponsive. I have not idea what happened!
 

·
Registered
Joined
·
75 Posts
I have 2017 SL. I went in a store and came out. The control panel touch screen as well as the buttons along the sides are unresponsive. I have not idea what happened!
I have 2016 SL with the same problem. It’s a known issue ( unit freezes) and I’m on my 2nd head unit and it still persists. I was hoping the problem didn’t persist on the 2017 unit.
 

·
Registered
Joined
·
1 Posts
I have 2017 SL. I went in a store and came out. The control panel touch screen as well as the buttons along the sides are unresponsive. I have not idea what happened!
What was the issue? I just bought a Murano and it's having the same problem
 

·
Registered
2019 Platinum 2WD White
Joined
·
10 Posts
I had an issue when starting up the radio would switch form sat radio to the CD. Also the control buttons would not work. The streering wheel controls worked fine. I ejected the CD and the issue is gone. The CD was a self made one. It played fine. I have not tried a factory made CD to see if the problem reappears but I will.
 
1 - 6 of 6 Posts
Top