Nissan Murano Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
I think the best thing to do is go into dealer and get it checked cause i cant imagine it being normal.
Its been pretty warm lately here in Iowa, high 80's 90's and with heat index sometimes its gotten to 105. With that being said i own a 2006 LS430 that i can have at 68-70 and its ice cold and speed level maybe on 2-3. If i put it down to COLD it gets really ice and i lower my fan speed to 1. Now the Murano just doesnt do such a great job. Ive recently ran it on FULL speed with it being set at 60 in the car for it to keep cool comfortable position. I also notice that when i auto start the car the AC turns on full blast and the air flow is much greater than when i put it on full speed, i can see why since the car is focusing all power on only running AC, but is that normal? 2015 Platinum.
 

·
Registered
Joined
·
114 Posts
Most Mo's will freeze you out so it doesn't sound like things are OK. Make a dealer appointment is my advice. We still have a lot of summer left!
 

·
Registered
Joined
·
67 Posts
Get a temp gauge and see what temp its pushing out. I did this recently and noticed that I had the temp in the car set to 66 it would blow out a few degrees colder at 60 for some reason. Not sure how the car is supposed to work but it was def blowing colder at 60. The temp outside was only 69 but it was really humid out so I was trying to get rid of the humidity.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
Yea definitely will be making an appointment. I realize the Murano has to work harder to cool a bigger cabin but its not much bigger than my LS430 so i just couldnt justify it lol. I will see what i can make work im doing two jobs right now and schedule is a little tight lol.
 

·
Registered
Joined
·
384 Posts
I find my Murano AC is the weakest I've experienced in all the cars I've owned. I too thought my AC wasnt working properly until I sat in a coworkers Murano and it was the same. He since traded it in for a Ram and sitting in that thing is like day and night in terms of the AC temperature output.

So yeah get it checked out just incase, but go in knowing that the Murano doesnt have a great AC system by any means.
 

·
Registered
Joined
·
194 Posts
My 2003's AC worked great for the 16 years I owned it.

The AC in my 2019 is works great too. Plenty cool, and cools plenty fast as well.
 

·
Registered
Joined
·
102 Posts
Your AC isn't broken the AC in the Murano just plain sucks. It's been in the 90's here and i have to put the AC on max and i still sweat, it takes a good 15 mins to cool the cabin. 2015 SV
 

·
Registered
Joined
·
194 Posts
Your AC isn't broken the AC in the Murano just plain sucks. It's been in the 90's here and i have to put the AC on max and i still sweat, it takes a good 15 mins to cool the cabin. 2015 SV
I have found it makes a huge difference whether the vents are pointed towards me or not. A minute or two with a vent blowing towards me cools me down fast, then I have to turn it upward and away from me because it's blowing such cold air.
 

·
Registered
Joined
·
2,548 Posts
You just need a little refrigerant top up.

Stick a meat thermometer in your center vent and if it blows over 50 deg after driving for a while with ac on then its on the warm side. All our cars blows around 40-42 deg even during our Vegas summer heat of 110 + deg. If its blowing between 40-50 deg is ok anything above is warm.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #12
the Murano AC is no match for the 100 degree scorching sun and high humidity where i live. Never again
haha man, i love the Murano looks inside and out but quality wise just aint up with the big boys haha. I mean its affordable and its what i need at the moment but boy what i would do to be able to jump into a GX460 or LX570. Im just poor and cant afford that right now!! lol
 

·
Super Moderator
Joined
·
7,624 Posts
I think the best thing to do is go into dealer and get it checked cause i cant imagine it being normal.
Its been pretty warm lately here in Iowa, high 80's 90's and with heat index sometimes its gotten to 105. With that being said i own a 2006 LS430 that i can have at 68-70 and its ice cold and speed level maybe on 2-3. If i put it down to COLD it gets really ice and i lower my fan speed to 1. Now the Murano just doesnt do such a great job. Ive recently ran it on FULL speed with it being set at 60 in the car for it to keep cool comfortable position. I also notice that when i auto start the car the AC turns on full blast and the air flow is much greater than when i put it on full speed, i can see why since the car is focusing all power on only running AC, but is that normal? 2015 Platinum.
Sometimes the problem is partial refrigerant charge. Before assuming you have a problem, have an AC shop check it and make sure it's fully charged.

As with most problems, figure out the simplest thing that could cause the problem and check that first. Before you assume all kinds of major problems, just make sure the AC is fully charged and working as planned.

My 07 Murano had great AC, but that's two models before yours.
 

·
Super Moderator
Joined
·
7,624 Posts
Sometimes the problem is partial refrigerant charge. Before assuming you have a problem, have an AC shop check it and make sure it's fully charged.

As with most problems, figure out the simplest thing that could cause the problem and check that first. Before you assume all kinds of major problems, just make sure the AC is fully charged and working as planned.

My 07 Murano had great AC, but that's two models before yours.
EXCELLENT idea, and it's free and quick!!

This filter is widely neglected.
 

·
Registered
Joined
·
27 Posts
AC systems are sealed systems. If your low on refrigerant than you have a leak. Very rare to have a leak on such a young vehicle. Unless it was never filled properly from factory or a cap was left off of low or high side of ac system.
 

·
Registered
Joined
·
66 Posts
Our last two Nissans had AC leaks (first two were fine, 1997 & 1999). My 2004Maxima had the low-pressure hose leak at the joint right in-front of the oil dipstick.
Very popular leak at the time... many had it. It leaked within 3yrs (but after 36Kmiles for me). Our 2007Murano had the high-pressure hose leak, around 5th year.
The hoses were >$250 alone ... For such $$$, shouldn't they last forever ?!!!!!
(edit: you could visually look around the AC hoses under the hood.IF you saw some green residue (could still be wet) near the joints, then... )
 

·
Registered
Joined
·
194 Posts
My 2003 Murano's AC worked great for the 16 years I owned it, and never required recharging, never leaked.
 
1 - 20 of 27 Posts
About this Discussion
26 Replies
14 Participants
Pilgrim
Nissan Murano Forum
We’re a community dedicated to Nissan Murano owners and enthusiasts. Discuss specs, safety rating, towing capacity and more!
Full Forum Listing
Top