Nissan Murano Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I bought a brand new 2011 murano SV last May 2011, currently at 10,000 KM, since then i kept comming back to the dealership (7 times already) for the same problem, the back up camera wont work. They change almost everything associated with the camera, i have to leave the vehicle there overnight and me end up commuting. As of this moment the camera is still not working. I'm tired and very dissapointed, I really love this vehicle and have it detailed everyweek, there's no single scratches on it, everywhere i go i used a valet service just to make sure it would be park safely, but everytime i returned it to the dealership to fix the same problem for them
ripping apart the component to tried fixing the problem i found small schatches everywhere inside the car mostly on the dashboard and around the shifter. I'm writing this for someone who can suggest what shall i do to
end my missery.
 

·
Registered
Joined
·
324 Posts
since it was brand new and has full 100% warranty, then you should return it to them. it has caused you enough problems already....
tell them to replace it with a new murano with a camera that works.
 

·
Registered
Joined
·
1,080 Posts
First I'd return to the dealer and demand they replace every scratched surface. Then I'd find another dealership to correctly diagnose and repair the camera issue. Hang in there...they'll get it right. Good luck!
 

·
Registered
Joined
·
1 Posts
I bought a used 2009 Murano and my back-up camera only works at night and inside dark places like a garage.
Any advice would be appreciated.
 

·
Registered
Joined
·
842 Posts
Did you buy it from a Vampire? lol

It sounds like the light compensating feature is stuck in night mode for some reason...Maybe resetting the head unit to the factory defaults in the settings menu will reset it, it's worth a try...
 
1 - 5 of 5 Posts
Top