Nissan Murano Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi, I have a 2006 Morano SE
Lately, I started to have problems with the air conditioner. Sometimes the air conditioner turns on by itself and there is no way to turn it off as all lights (Auto, off, a/c…) go off. Also, all other buttons don’t work, no CD, no radio, no tape. Last night, I went fishing in Lockport Manitoba, when I came back (2 AM), the air conditioner still running and pushing cold air inside the cabin. It was freezing inside and felt like winter is back again.

Any info would be greatly appreciated, thanks
 

·
Registered
Joined
·
2,393 Posts
Last night, I went fishing in Lockport Manitoba, when I came back (2 AM), the air conditioner still running and pushing cold air inside the cabin

It runs with the engine off???
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
No, I didn’t any key in the car.
What I meant was that when you turn the ignition key to position 2 and 3, the air conditioner starts working but the lights and control buttons are all off (not working)
 

·
Registered
Joined
·
120 Posts
The A/C compressor can't run without the engine running - it's mechanically impossible. What you're saying doesn't make sense, unless you left the car running while you went fishing. Are you trying to say the blower is on? If so, though, that wouldn't make your car ice cold unless it was already ice cold outside.

I think there's some info you're not sharing...
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
No, I left the engine off when I went fishing. The cabin got very cold after I drove 1/2 hour or so with the air conditioner running. When the engine is turned off and the intelligent key is locked, the air conditioner also goes off. but when you turn the ignition key to position 2 and 3 the fan starts running, and I cannot turn it off as all lights (OFF, A/C,...) are off
 

·
Registered
Joined
·
120 Posts
Okay, well that makes sense. :)

I have no idea what would cause it. Relay. Circuit board. Stuck button...

Is it stuck in a particular mode, such as vent, feet or windshield defrost? I'd try depressing the front and rear defrost buttons a few times, as well as the mode and dual buttons, just to try to jog something. Can you get heat at all? Can you adjust the temp settings? If no dice, I'd disconnect the battery for a minute, then reconnect it and see if everything resets itself.
 

·
Registered
Joined
·
12,664 Posts
OK, let's start over. If you get into your car right now and start the engine the HVAC fan comes on, right? Now if you press the HVAC's OFF button the fan remains on, is that what you are saying?

-njjoe
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Nothing is working. I don't get heat, I can't adjust anything including the temp settings as all buttons don't work (lights off). the screen is stuck on TRIP. I checked fuses, thy seem fine.
Now that you mentioned circuit board, I remembered that this problem occurred only while I was driving on a bad street. Could it be a circuit board?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
Yes njjoe, if I start the car now, the HVAC fan start running and I can't turn it off as all control buttons are not working, and I can't adjust any settings
 

·
Registered
Joined
·
12,664 Posts
Cd-

The MO's HVAC system has a self-diagnostic function built in that enables you to test the operation of each button. Here's the procedure from the Service Manual:

HVAC Button check.jpg

-njjoe
 

·
Registered
Joined
·
49 Posts
I Think its a blown fuse, check fuses under dash and near battery. My 05's head unit was doing the same thing and it was caused by a blown fuse.
 

·
Premium Member
Joined
·
8,402 Posts
Its definitely a head unit control issue - the advice above to check the fuses is good.

Joe did a good job clarifying the issue. The OP said the "air conditioner kept running" - the fan and the AC are two different things. The fan just pushes air. The AC cools and dries it. It sounds like there is a circuit board issue, a possible BCM issue, but I'd check the fuses first. Your owners manual shows the location of the various fuse boxes.
 

·
Super Moderator
Joined
·
8,221 Posts
You can always unplug the electrical connector from the compressor - then the AC can't run.
 

·
Registered
Joined
·
6 Posts
I had the same problem. Well it appears that the Nissan dealer has fixed my problem with the Radio and Heat/AC controls not working. The service manager told me it was the Heater and Audio Control switch assembly. They had changed out everything else in the system alsto find it. Thank goodness when we bought it it had an extended warranty that covered thes problem. They also fixed the fuel tank issue of not letting gas go in quickly. A couple of gold Stars go out to New River Nissan in Virgina.
 
1 - 20 of 20 Posts
Top