Nissan Murano Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have a 04 SL (w/out nav) and I am having a problem that when I turn off the car, the display will not turn off. I have looked through the manual and cannot find anything on this problem. I was just wondering if anybody has had this problem or maybe knows how to fix it. Other than this I have really enjoyed my MO and have also enjoyed this forum.
 

·
Mr. 3 K, 3/3/5. 5K,10/5/7
Joined
·
4,994 Posts
You most likely have a defective Intellegent Power Distribution Module go see the dealer.
 

·
Just wanna help
Joined
·
1,383 Posts
Even after a while, the display still wont go off?

Becareful, you may drain ur battery and wont be able to start the MO in the morning.
 

·
Premium Member
Joined
·
8,368 Posts
If worse comes to worse, you can always set the climate control to off, radio to off, and leave just the outside temp lighted up on the center display if it will not turn off, to save as much battery as possible. Setting the screen brightness to the dimmest setting will also minimize battery drain.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Well I can turn it off manually when I am done but its still a hassel. I was thinking that it might be in the settings because my friend was messing with the buttons and now it doesnt turn off. But I have tried every setting and also resetting the settings and it still wont turn off automatically when I turn the car off. Oh well, looks like I will have to turn it off manually until the weather gets better so I can take it to the dealer (about 3 hours away). Thanks for the help anyway.
 
1 - 5 of 5 Posts
Top