Nissan Murano Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone. I have a 2004 Murano FWD. I recently installed new Cam Position and Crank Sensor and throttle body cause the car was running horrible and I get a check engine light for high idle. I did the re learn for the new throttle body but I am still getting a high idle. Another issue I‘m having after replacing everything is although I know its a CVT transmission when I an coming to a stop it at around 15 MPH the tranny jumps a little. My local mechanic says I need a new transmission but it started doing this after I changed everything so I know its not a transmission problem. If any of you know what may be the cause the hell would greatly appreciated. I am also in Long Island NY if anyone knows a good tech that would be able to properly diagnose. Thank you.
 

·
Registered
Joined
·
766 Posts
The slight lurch/jump when decelerating through around 15 MPH is perfectly normal for your CVT, it's the torque converter lockup releasing. Sometimes it's more noticeable than other times... It also may be more noticable due to the higher idle...

I've heard the idle may relearn on its own over a small period of time, but maybe others can provide more insight.
 

·
Registered
Joined
·
568 Posts
Hello everyone. I have a 2004 Murano FWD. I recently installed new Cam Position and Crank Sensor and throttle body cause the car was running horrible and I get a check engine light for high idle. I did the re learn for the new throttle body but I am still getting a high idle. Another issue I‘m having after replacing everything is although I know its a CVT transmission when I an coming to a stop it at around 15 MPH the tranny jumps a little. My local mechanic says I need a new transmission but it started doing this after I changed everything so I know its not a transmission problem. If any of you know what may be the cause the hell would greatly appreciated. I am also in Long Island NY if anyone knows a good tech that would be able to properly diagnose. Thank you.
When you say high idle--how high is it? Before you did the idle relearn, did you do the accelerator pedal released and throttle body closed relearn procedures?

I do recall reading about people having trouble with the idle relearn with the 1st generation Muranos--sometimes needing to try it several times before it takes. You also need to be precise with the timing (i.e. use a stop watch) and make sure all the initial requirements stated in the service manual are met (e.g. coolant/CVT temp, no electrical loads, steering wheel straight etc). You can also try using the CVTz50 app to do it if you haven't already.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
When you say high idle--how high is it? Before you did the idle relearn, did you do the accelerator pedal released and throttle body closed relearn procedures?

I do recall reading about people having trouble with the idle relearn with the 1st generation Muranos--sometimes needing to try it several times before it takes. You also need to be precise with the timing (i.e. use a stop watch) and make sure all the initial requirements stated in the service manual are met (e.g. coolant/CVT temp, no electrical loads, steering wheel straight etc). You can also try using the CVTz50 app to do it if you haven't already.
The idle is just over 1,000 RPM at normal temp. Yes I did the accelerator and throttle first. I will download the app. I never knew about it. I’ll let you know how I make out. Thank you.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
The slight lurch/jump when decelerating through around 15 MPH is perfectly normal for your CVT, it's the torque converter lockup releasing. Sometimes it's more noticeable than other times... It also may be more noticable due to the higher idle...

I've heard the idle may relearn on its own over a small period of time, but maybe others can provide more insight.
The only way to fix the torque convertor is by replacing it or rebuilding it? Is it normal that for the past 2 years it never did that until I did the serivce?
 

·
Registered
Joined
·
766 Posts
The CVTz50 app will scan for TCM CVT and ECM engine error codes. Let us know if you see any error codes.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Good news fellas. I was able to contact a friend of mine at Nissan about the re learn. He had me bring it down and tried to do the re learn 3 times and it did not work. So he wound up hooking it up to the Nissan computer and updated all the data. Turns out thats what I needed cause the new items I installed would not work with the ild software. Car idles perfect now and does not do the jump at low speed anymore. And I also had 2 new flex pipes installed since mine were making noise and the car runs better then when I bought it 2 years ago. Thank you guys for the help.
 
1 - 7 of 7 Posts
Top