Nissan Murano Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,393 Posts
Discussion Starter #1
I had this 7" GPS in the dash of my '03. Have to do it all over again in the 07. This will be in installments. Too hot (94) out there to do it all. Spliced into the factory rear view camera signal at the display, connected it to the AV input to the Magellan and it worked fine. Mounted the Magellan using a drastically modified OEM cradle, and cutting the plastic underdash structure so it would mount to the metal brace in the center of the dash. That is where I stopped today. I am still using the lighter power cord. I have to pull the radio to get permanent power. After I get the power, I will install the RGB to composite converter to display the factory radio and AC that were on the replaced factory display.
I will try to take pictures later.
The net result of this is better than OEM GPS fpr less than $200
 

·
Registered
Joined
·
2,393 Posts
Discussion Starter #3
All working. Got the power done and finished the RGB to Composite converter wiring. Still need to locate the display (from GPS to radio) switch and fine tune the display mounting..
 

·
Registered
Joined
·
2,393 Posts
Discussion Starter #6
Been a couple of years. I have been trying, without success until now, to get one of the more up to date Magellans with a good Bluetooth into the '07. The Magellan 9055 and 9250 were not compatible with the RGB converter for the vehicle displays. I just got the new 9465T-LMB unit and it works! A lot of changes, different power connector, different case, and a different mount, have caused quite a bit of rework. Almost done.....
 

·
Registered
Joined
·
2,393 Posts
Discussion Starter #7
Back to the 1700. There was a ground isolation fault between the 9465 and my RGB/Composite converter that interfered with automatic turn on. I was just too old and tired to sort it out.....
 
1 - 7 of 7 Posts
Top