Nissan Murano Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hello All,

After extensive research on this forum, as well as a week's worth of email correspondence with Joying, I decided to purchase the following head unit for my 2017 Murano SV: Nissan Murano 2015+ Aftermarket Stereo Upgrade Android 8.1 Car Sound System with Big Screen

I was assured by Joying several times that the head unit would be compatible with my Bose system and 360 degree camera. They sent the correctly sized harness, but that's about where the good times end.

Joying has been very responsive and has involved one of their engineers, but while they are researching, I was very much hoping that members here might have some guidance or ideas. I recorded a video of the problem I'm having: Joying Install

With everything connected, including the A/C module, the head unit turns on (audio, radio, GPS are OK), but the car doesn't start, steering wheel controls don't work, etc. Pressing the ignition button twice gives me power, but after a second or two, the engine fan turns on permanently along with a high pitched tone, then nothing else happens. Once I get to this point, the ignition button stops working and I'm forced to disconnect the battery to shut things down.

My only guess is that the connections provided by Joying have something missing, or are maybe pinned incorrectly, but I have no experience with this so is only conjecture. Or maybe I'm doing something wrong.

Any suggestions would be greatly appreciated.

Thanks,
Alex
 

·
Registered
Joined
·
959 Posts
Hi @Frederaj ,

Sorry to hear you are having some issues.

I have the same model minus the physical button on my SV, hook up was easy and straight forward. I have it hook up with 2 rear camera, one is using the backup camera, and the other is a HD USB cam hooked up on the rear that allows me to view the back while driving, also records when it is on.
I am using the SPDIF output going to a external DSP, then to an amplifier and finally to my 6 speaker system + 2 subwoofers. The sound it produces is excellent...

Joying in my opinion has the best android head unit, and I tried many of them. But unfortunately, the Bose system does not seem to work very well with these head unit, some people in this forum did got it to work, but had to add additional component.
Bose system is so tightly integrated that it is very difficult to replace just one component and have the best sound. If you have the bose, you need to use the low level input (RCA) from the head unit, since you have already an amplifier.

I watched your video, and all your connections seem to be correct.
As you can see, you have 2 connectors, one 20 pin and the other 40 pins. The 20 pin is for power and sound and the 40 pin is for your backup camera and SWC which uses digital CANBUS. You should have also received a CANBUS decoder from joying, this decoder takes your input from your head unit and translate them to a digital input the Murano understand.
The CANBUS is connected to the ECU (Engine Computer Unit, which basically control the whole electronics of the car including the AC, fans, etc... This is probably where the issue lies. The DECODER they sent you is probably not programmed correctly. When the ECU sees input from the decoder it cannot understand, it will not operate correctly.

I would try this test just to rule out the decoder. Connect just the 20 pin connector, and try to power on the car, if it comes on then the issue is the decoder that is connected to your 40 pin connector.
 
  • Like
Reactions: Frederaj

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Hi @assad ,

Thanks for the reply! I do really like the head unit and you're right that it sounds great. It seems to me that the 20-pin connector is wired OK as power and audio are good to go, even with the Bose setup.

I really appreciate your suggestion - I was able to start the car no problem with only the 20-pin connected. Once I connected the 40-pin, the same issue occurred and the car didn't start, not to mention no SWC functionality nor cameras.

I'll take this feedback to Joying and suggest that there may be an issue with the CANBUS. I'll update the thread as things progress.

Thank you.
 

·
Registered
Joined
·
959 Posts
Also, I forgot to mention, make sure to reconnect the AC module at the bottom before powering on your car. It has a 20 pin connector also, do not mix them up.
On many occasion, I forgot to reconnect it, and the car was doing all sort of crazy things.

I am pretty sure they programmed the CANBUS module with the base model, most of their testing is done on the base model. Not sure if they have the programming specs for the Bose model, since it would be different.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Thanks, yep I made that mistake once and quickly learned from it. Fingers crossed that they can get me up and running, but they mentioned that there was limited information on my model; I'm not too confident.. though I was assured that it would be compatible.

I suppose if this doesn't work out, I'll give the Dasaita MAX6 a shot. Hoping that Joying can sort it out, though.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
Joying sent me a new harness and I had a chance to test it today. The good news is the car started with both 20- and 40-pin connectors attached. Still no cameras, nor any support for the SWC.

One step in the right direction, but still a way off from being fully functional. I've written an email with more feedback for them to review - we'll see what happens next.

New Joying Harness.jpg
.
 

·
Registered
Joined
·
959 Posts
Go into your advanced settings (there is a 6 digit passcode), and make sure the car selected is either nissan or datsun
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
Thanks for the suggestion, assad. Joying asked me to do the same thing plus an additional step for the CANBUS configuration. They provided the code, so I went in and tried both settings on the attached image, but still no SWC nor any feed from even the factory back up camera, let alone the 360 image.

More feedback for Joying to review.

51704
 

·
Registered
Joined
·
959 Posts
Definitely CANBUS issue.
Have you tried other car model?

If you want I have a CANBUS, but it is for the SV with no 360. If you want I can send it to you for you to try, but I doubt it will work.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10 (Edited)
I haven't tried other models, but I have some time today so I'll play with it and see if I can get anything at all to work.

I'll keep your offer in mind, thank you.

edit: no other models nor CANBUS types made any difference.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #11
Joying is sending me two more harnesses (#3 & #4) as well as one more CANBUS (#3). I'll update when I test them - DHL normally takes about four business days to deliver.

They seem determined to get this working, so I can at least take some comfort in that.
 

·
Registered
Joined
·
2 Posts
Following this closely to see if you get it to work all. I'm interested in buying the same model, hopefully it works out for you. Keep the updates.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13
I received two new harnesses and one CANBUS. Both of the new harnesses are more complicated than previous versions.

One harness is much larger than the other and looks very close to the harness pictured on the Dasaita MAX6 product page, for what that's worth. It has additional AUX plugs, a new 32 pin connector, and a couple other things. The separate radio plug is different, so we'll see how that works.

More feedback to come once I get things plugged in and tested.
51751


51752
 

·
Registered
Joined
·
959 Posts
Good luck!
I just got the Dasaita max6 today, and it came with android 10. I am currently bench testing it.
My canbus adapter looks a little different than yours
51753
51754
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
Very nice!

The MAX6 was the other option I was seriously looking at. Hopefully I won't have too much buyer's remorse and Joying can get me up and running soon.
 

·
Registered
Joined
·
959 Posts
Absolutely not, you won't have any buyer's remorse, i have been using Joying for the past years and it is a great unit, never had any major issues with it, very stable. The only thing is Joying is slow when it comes to software updates or upgrading their apps, they are still running android 8, they are more focus in making units for every cars out there.
The PX6 chipset on Dasaita seems to be a little faster than the Intel chipset.
Both units have extensive support on xda-forum, with custom rooms and mods.
If you can get this to work, I am sure you will like it.
 
  • Like
Reactions: Frederaj

·
Registered
Joined
·
1 Posts
Crossing my fingers this gets solved, I’m jump on something in a heartbeat to keep the Bose, 360, and steering wheel controls!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18
I've emailed Joying a few questions about the new harnesses, so I should be able to provide another update after the weekend. Their customer service is top notch.
 

·
Registered
Joined
·
959 Posts
Right, they have excellent customer service, i second that.
Spent all morning today installing the dasaita max6, and I was pleasantly surprised. Everything worked right out of the box, also better radio reception. I saw some setting in there for 360 camera, but dont have it.
I would give this a slight edge over joying, notably because their software is better integrated with the unit, sound quality is about the same, both use the same sound amplifier chip, dsp on both unit are pretty much similar.
If you are using an amplifier, the rca pre-out on the dasaita is better, I measured 1.8V with my multimeter, on the joying it was slightly less than 1V. I will calibrate my amp tomorrow.
51755
 
  • Like
Reactions: PaulDay

·
Registered
Joined
·
14 Posts
Discussion Starter #20
Great info, assad, thank you. If Joying can't get this resolved for me, the MAX6 will be my next experiment.
 
1 - 20 of 26 Posts
Top