Nissan Murano Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
I pulled the link for the NHTSA from this web-site. Since more and more reports are coming in everytime I view this site, I decided to report the incident. I went through the whole process (rather painstaking). When I pushed the submit button a notice came up that the link is not valid or it has errors.

Any idea on how to fix this? Shall I go direct?
 

·
Premium Member
Joined
·
8,402 Posts
chita1987usa said:
I pulled the link for the NHTSA from this web-site. Since more and more reports are coming in everytime I view this site, I decided to report the incident. I went through the whole process (rather painstaking). When I pushed the submit button a notice came up that the link is not valid or it has errors.

Any idea on how to fix this? Shall I go direct?

Did you mean you experienced an error on the NHTSA website? Or the link from this website?

Here is the link to the NHTSA form submit site for complaints for your alternator.

NHTSA report a complaint
 

·
Registered
Joined
·
57 Posts
Discussion Starter #3
Thanks for the new Link

Thank you Eric L. for the reply.. the new link I pulled from your reply
worked and I got a confirmation number for my complaint.

Hopefully if all MO owners report the problen, we can have a better chance of being heard.

Thanks again
 

·
Love to live w/ MO
Joined
·
419 Posts
speaking of that,
i got a call from Washington DC from a lady in NHTSA. they said they are still investigating in the issue of the alternator failure.
they needed some morei nfo from me and "WILL CALL ME BACK"
will post more info as i get it
 
1 - 4 of 4 Posts
Top