Nissan Murano Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am not able to reset clock in Murano dashboard.
I tired almost everything.
I ran self-diagnostic page and I got Control Unit issue.
Do you have any idea about below photo?
Please help me.
Gadget Display device Multimedia Electronic device Output device
 

·
Administrator
Joined
·
9,659 Posts
Did you check the owner's manual?
 

·
Registered
Joined
·
1,310 Posts
Aside from reading the manual to gain clarity and possibly checking for a bad fuse/relay, you could chance disconnecting the battery leads for a minute and then reconnecting them to see if that solves the problem. Maybe press and hold the POWER/VOLUME and TUNE/SCROLL buttons for I think five or so seconds, and that will reboot the head unit. Those things are what I would first try if I had problems.
 

·
Registered
Joined
·
135 Posts
Mine set's itself. I had the battery disconnected numerous times recently (see previous alternator and sunroof posts) whenever I would pull out of the garage after reconnecting the battery the clock would set itself. I think the only clock options on the models with nav are 12hr/ 24hr time and turn auto timezone adjustment on or off.
 

·
Registered
Joined
·
53 Posts
Im not sure about this particular year, but do check the fuse box for the Extended Storage Fuse---it's used for shipping, and holding/retaining info aside from the mains, if equipped. Usually has a white plastic protector on it and if displaced or blown can usually trip up some of the electrical components, yes including the infotainment unit. Pushing on it to reseat can fix quirky issues like this. Ive seen it at a level where the clock and radio settings would be lost everytime the car was shut off and no one could figure it out. A buddy of mine passed on this information to me years ago, and still sticks in the memory as it gets overlooked by many of the best techs. Also just look around inside, but behind the console for a cable that may have come loose or disconnected. It just looks that obvious but may not be that simple....make sure to stretch a bit----get in there with a flashlight and be prepared to contort yourself into positions you didnt know you could.

Just eliminate that, reset the radio and/or disconnect battery for a few minutes and carefully reinstall cable, and hope for the best. Head unit could be junk, but you wont know until you dig a little deeper.

Ebay has a good aftermarket inventory for things like this, if the head unit does need to be replaced.
 
1 - 6 of 6 Posts
Top