Nissan Murano Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I have an 07 SL with 55,000miles. The turn signals do not have the "Tick Tock" sound anymore. Complete silence. Any ideas?
 

·
Registered
Joined
·
125 Posts
If everything else is working fine, you should be relieved. That ticking sound gets to be annoying.
 

·
Registered
Joined
·
1,080 Posts
Im surprised their working since that ticking is the relay that makes them flash. Just replace the flasher relay. I'm sure the dealer will point it out for you.
 

·
Registered
Joined
·
12,664 Posts
Im surprised their working since that ticking is the relay that makes them flash. Just replace the flasher relay. I'm sure the dealer will point it out for you.
That was true in older cars, but not the MO. There is no "flasher", it is controlled electronically, and the same circuit triggers the buzzer.

-njjoe

Sent from my DROIDX using AutoGuide.com App
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Yes everything work except for the sound at times. The sound only seems to disappear one out of ten times. And of course the first thing i did was put fresh batteries in my hearing aid! Thanks Zebelkhan! I wish it was as easy as replacing a relay! But its not.
 

·
Registered
Joined
·
1 Posts
turn signal audible clicks

Yes everything work except for the sound at times. The sound only seems to disappear one out of ten times. And of course the first thing i did was put fresh batteries in my hearing aid! Thanks Zebelkhan! I wish it was as easy as replacing a relay! But its not.
I started having this problem this weekend install a metra dash kit. Attached everything back up and I don't get turn signal sound. Also trip counter a and b on dash reset themselves and dimmer always coed on at brightest level. Any seem any of these?
 

·
Registered
Joined
·
97 Posts
turn signal sound comes from an electronic signal in the instrument cluster attached to a small speaker, it's tied directly to the indicators on the cluster, not the actual turn signal lights or relay.

Unfortunately you have a bad connection or a short either on the cluster's board, or in the wiring. It may also be that the speaker has just died...

try the emergency flashers, see if you get sound, if you do, the flashers are on a seperate circuit, and you can rule out a dead speaker or bad signal wire to the speaker.
 

·
Registered
Joined
·
1 Posts
turn signal audible clicks



I started having this problem this weekend install a metra dash kit. Attached everything back up and I don't get turn signal sound. Also trip counter a and b on dash reset themselves and dimmer always coed on at brightest level. Any seem any of these?
Did u ever figure out what your problem is? I'm having the same problem. My middle screen has went out as well
 
1 - 10 of 10 Posts
Top