Nissan Murano Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
My 2020 Murano Platinum is not recognizing and connecting my android phone , It has the phone on the system but it doesn`t connect it . The screen keep saying "connection has failed" ... man , this is ridiculous ...!!!
Now a days, when Bluetooth connection for phones is as common as water , this thing is not working .
I have an incoming appt for oil service this month so I am taking this problem to the dealer to be fixed somehow . Maybe it needs an update ? who knows, I `ll find out in 2 weeks , but it is very annoying for sure .
 

·
Registered
Joined
·
1,335 Posts
Have you checked your owner's manual on the process to pair your phone with your Murano?

I haven't had any issue with my '19 pairing correctly which has the same head unit...
 

·
Super Moderator
Joined
·
8,580 Posts
With a variety of cars, I've had to make multiple attempts to pair phones. Usually it goes well, but in some cases I've had to dig through the owner's manual and make 5-10 attempts. In a couple of cases I had to wait for software updates on the phone(s).

I would encourage you to check the procedure and try repeatedly. You should eventually win.
 
  • Like
Reactions: MuranoSL2003

·
Registered
Joined
·
10 Posts
Discussion Starter #4
I had the car for a year and it has been working well all that time ... until a couple of weeks ago .
I have tried a few times and even unpaired the phones (my wife`s and mine) completely and paired them again and it will work and switch phones correctly ... until the next morning , when the whole thing got back to : "connection have failed" even thou the phones are paired and on the system , but it would not connect either of them at all . The screen then will say " phones are not connected " ...!!!! Very frustrating , I must say ...!!!
 

·
Registered
Joined
·
1,335 Posts
Technology is like that, often times glitchy and frustrating...Take your time, check for updates, try different things, multiple times, read the manual, multiple times, research, persevere...

I have been dealing with it since the mid 70's in the computer industry. Things were a whole lot more glitchy back then, and for decades after, getting anything to run 24/7 reliably was often a pipe-dream...
 
  • Like
Reactions: Pilgrim

·
Super Moderator
Joined
·
8,580 Posts
Technology is like that, often times glitchy and frustrating...Take your time, check for updates, try different things, multiple times, read the manual, multiple times, research, persevere...

I have been dealing with it since the mid 70's in the computer industry. Things were a whole lot more glitchy back then, and for decades after, getting anything to run 24/7 reliably was often a pipe-dream...
I think in that regard, progress is shown by the fact that we actually expect it to work, rather than being pleasantly surprised when it does.
 

·
Registered
Joined
·
11 Posts
I had an issue where my radio didn’t have my selected xm channels available. The line where they were wasn’t even there. I had to pull the negative wire on the battery. That fixed it.
 
1 - 8 of 8 Posts
Top