Nissan Murano Forum banner

1 - 8 of 8 Posts

·
'03 SE 2WD Cold Pkg, VDC
Joined
·
143 Posts
Discussion Starter #1
Is the washer fluid suppose to spray out onto the back window. Mine just dribbles down the window.

Any ideas on how to clear the nozzle or fix this? Is there a separate reservoir for this washer? Maybe the pump is bad?

thanks
 

·
Registered
Joined
·
53 Posts
Mine just comes down as a single stream right in the middle of the window, the wiper spreads it out from there....
 

·
Registered
Joined
·
174 Posts
There is only one reservoir for both the windshield and rear window.
When operating properly there is a good flow of fluid to the rear window.

I've had these systems plug up in the past but not on the MO yet. Usually after a long period of inactivity. I use a needle or pin to try and clean out the gum accumulated in the nozzle.
 

·
Premium Member
Joined
·
7,136 Posts
Trev said:
I've had these systems plug up in the past...
I agree and I bet that is what you have. Mine looks like a heavy spray, or one very strong stream. You may have some wax that has built up inside the nozzle. Just take a pin and clean it out.
 

·
Registered
Joined
·
415 Posts
Very interesting...I have an S trim. Does anyone know if this feature is on the model cause I don't get any spray / stream whatsoever?!!!!
 

·
'03 SE 2WD Cold Pkg, VDC
Joined
·
143 Posts
Discussion Starter #6
Thanks everyone for your response...

You need to move the washer stalk towards the dash (I think) to activate the rear washer.

Eegads.... wax build up!
 

·
Premium Member
Joined
·
8,368 Posts
LKimura said:
Thanks everyone for your response...

You need to move the washer stalk towards the dash (I think) to activate the rear washer.

Eegads.... wax build up!
Thats right. Push for rear washer, pull for front washer.

My rear washer dribbles out as well.
 
1 - 8 of 8 Posts
Top