Nissan Murano Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello everybody I'm new here friend of mine but a 2004 Nissan Murano SL now one day the car was running perfect I check the oil oil with a little bit low so I can change it out it started ticking check engine light so then we did Diagnostics on it turns out that it said that it was the VVT solenoid so I Changede both out car still runnin the same skip in ticking no power so then diagnostic told me to change spark plugs multiple coil miss fiers so I did that change all the coils out yesterday plugs and then put the intake back on then it read a started it up it wouldn't even run one even past 2500 RPM's diagnostic again and now it said the code for the Mass air flow sensor now theother other day said it was the rear fuel rail damper which is making the tick have that on order now but what I'm asking is could it be the timing chain guides could it have jump time? Due to the guides being wore out it only has 136000 miles on it
I don't know personally I'm confused I'm about fed up with it I told her to take it to a dealership and its going to cost her a lot of money to get that stuff done you guys have any input on what else could be thanks guys appreciate it!
 

·
Registered
2011 Nissan Murano LE AWD
Joined
·
1,311 Posts
I did that change all the coils out yesterday plugs and then put the intake back on then it read a started it up it wouldn't even run one even past 2500 RPM's diagnostic again and now it said the code for the Mass air flow sensor
This is what would happen if the engine is started and the MAF sensor was disconnected (was the DTC P0102?). Unplug the MAF sensor, check the pins and make sure the connector is clean and plug it back in making sure it's pushed in all the way.

You didn't say whether or not the VVT codes came back. Have you used a mechanic's stethoscope to see exactly where the "ticking" noise is coming from?
 
1 - 2 of 2 Posts
Top