Nissan Murano Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have an 04 satellite ready. I followed the instructions for installation xm found on this website. However, my headunit seems to only display station information (or anything) for about a tenth of a second, then the screen reverts back to "Antenna". Thats all it says.

I can change the station but again, station id or song title or anything only flashes on the screen and back to antenna.

Anyone have any suggestion as to why this is happening?
 

·
Registered
Joined
·
195 Posts
Try the "Audio" button

Well,
I don't have sat tuner yet but it's my understanding that if you press the Audio button a couple of times you will have the option to change the display options Track/Artist, etc.. That would be my guess..
 

·
Moderator
Joined
·
4,601 Posts
One of your antenna connections is bad. It puts that on the display, if there's a problem.

If you are using a splitter, that might be the problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
hmmm.... thanks jaak.... do you think it'd be that i'm using a terk antenna with the infinity xm tuner? oh... and does the antenna plug into the yellow or green inputs on the tuner? i thought that might be a problem too...
 

·
Moderator
Joined
·
4,601 Posts
The tuner looks at both inputs and if one of them is not connected, will display the Antenna warning you see.

I don't remember which is which, but one input is for the satellite and the other for terrestrial antennas. The first antennas had two wires, one for each. Some of the later antennas have one wire and require a splitter to connect to both.

If you don't have two antenna connections, go back to your supplier and ask them for the splitter, or a different antenna.

The tuner is identical for ALL Nissan's and Infiniti's, so the tuner is not the issue. My tuner was destined for an FX, but of course, never made it to one.

So the tuner is compatible.
 
1 - 5 of 5 Posts
Top