Nissan Murano Forum banner

1 - 4 of 4 Posts

·
Love to live w/ MO
Joined
·
410 Posts
Discussion Starter #1
hi, ever since winter is gone, while cruising on to 50kmph mark my MO's steering gives me kind of a vibration and it seems the whole front part of MO is vibrating since i can feel it around me..... is that something normal ?

im at 40,000 km and my warranty expires in May but i do have the extended coverage.

any ideas on what would cause this ???

is that the symptoms for the famous STEERING WIGGLES issue ?

i am scheduled for my fuel shield installation on thursday, and i am getting my oil change that day as well, so i will talk to the dealer about it but would like some experienced views about it.

PS> my last oil change was in Nov 2005 and so far i have done 4,000 km on it. (using Mobil 1 and k&n filter) in case this information might help you !!

thanks,
 

·
Registered
Joined
·
12,512 Posts
hasaanbhutta-

I am not even going to attempt an answer. I just wanted to chime in and say I love your avatar! :29: That's pretty slick.

-njjoe
 

·
Registered
Joined
·
2,057 Posts
No that is most definitely not normal, have the dealer look at it. I can't imagine how engine oil and air filter would have anything to do with it. There are several things that can cause it, too hard to say without investigating the car. I would look first for a tire or wheel problem and then proceed from there through the hub, brakes, rack, pump and belt.
 

·
Registered
Joined
·
415 Posts
Coming from a total noob here, but could it possibly be because of your alignment? Sometimes I've noticed (on previous cars) that if my alignment is off, the steering wheel vibrates / shakes.
 
1 - 4 of 4 Posts
Top