Nissan Murano Forum banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
2,226 Posts
Discussion Starter #1
Awwww crap! My first problem just came up on my '05.

In the last couple days, the channel up/down lever on the steering wheel occasionally doesn't work. All other steering wheel controls work fine. If I turn the stereo OFF, then back ON, then it starts working again.

Anyone else ever notice something like this? Any ideas? Perhaps a loose connection or something, but seems strange that cycling power restores functionality (for a while anyway).

It's an intermittent problem, so obviously Nissan will be no help at all.
 

·
Premium Member
Joined
·
7,136 Posts
Did you try to see if the button on the HU works when you have that problem? Does the volum control still work when the channel button does not? Do you have a PAC audio? It is possible that it is not the steering controls and the xm unit is causing an issue with the HU. The reason I say that is because I have a simillar issue as well. I have a PAC audio unit installed (which talkes the place of the OEM satelitte on the wiring harness). Input-1 is connected to my PC. Everything worked fine until I got a XM-Direct and connected to aux-2 of the pac unit. Now when I try to switch from aux 1 to aux 2 (by pressing the ABC button). Then all controls stop working until I turn the HU off and then on. Volume also drops to zero. Switching from aux-2 to aux-1 does not create the same problem.
 

·
Premium Member
Joined
·
8,368 Posts
The intermittent problems are the worse, since the diagnostic ability of the dealership is worse than if you let a "barrel of monkeys" take a crack at it.

I admit that even when I listen to the radio, I hit the presets on the stereo face (the big round buttons are super easy, unlike the close together number buttons on other cars). Perhaps you can try fiddling with the stereo face controls (before you turn off the radio) to see if touching one of those buttons "restores" the steering wheel control. I know its not a solution, but it certainly helps to diagnose the problem yourself so you can pin down a pattern to report to the Nissan dealer.
 

·
Premium Member
Joined
·
2,226 Posts
Discussion Starter #4
No PAC, factory installed XM unit.

Volume controls on the wheel work, as well as mode and power. I can change presets by hitting the buttons on the main stereo, I can switch to normal FM and back to XM and still have the problem. Haven't tried using them when I'm not on XM, though, I'll see if I can do that next time.
 

·
Registered
Joined
·
44 Posts
Had the same problem with 2003 SL - within 3,000 miles after delivery - was fixed with warranty replacement of the wiring harness in the steering wheel.
 

·
Premium Member
Joined
·
2,226 Posts
Discussion Starter #6
Certainly isn't just the XM. Happens for all modes. Always seems to be fine if I tun the stereo power off and back on.

If it gets worse, I'll take it in and have them replace the wiring harness like you say. Thanks for the input!
 

·
Registered
Joined
·
4,077 Posts
I have an 03 SL and had issues with changing the channels. Intermt.

The dealer was not able to reproduce it (no surprise). At the second visit I drove with two service guys and finally showed them. Then the SM says... not sure how to fix that implying that I should just deal with it.

Of course I was not going to do that. End of the story was they fixed it under warranty by replacing some sort of spiral cable. While they were at it they also fixed the intermt door locking issue. Here are the parts they replaced for everything:

22567-CD002 Body-Combi
2550-CA000 Switch-Asmb
24125-CA002 Harness Assembly

Not sure what was for what.
 

·
Premium Member
Joined
·
2,226 Posts
Discussion Starter #8
Thanks, JMcDonald and Gonzo! I'm OK with it right now, but if it gets worse (or I get more annoyed) then your two posts will help me deal with the dealers (hmmm... sounds like there's a pun in there somewhere...)

There's a new Nissan dealership in Bellevue that just opened a couple months ago, and it's the closest one for me. They seem really eager to please so far (I've bought a few oil filters, they gave me a pretty good discount) so perhaps they'll be a little better than the avarage Nissan idiots... :rolleyes:
 

·
Love to live w/ MO
Joined
·
410 Posts
had this issue with my 03 as well.. just explained it to my dealer and he got me a replacement switch for my steering wheel and off i went with my MO......

no problems after that yet....
 
1 - 9 of 9 Posts
Top