Nissan Murano Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I dont have a mUrano but my uncle does..i got a 350z...but anyways when he turn off his A/C runnin for like 15-30 mins HE hAS A BAD bAD SMELLL when just runnin regular air....after turnin off AC. Just want to know did anyone of ya have the same experences???
 

·
Registered
Joined
·
4,077 Posts
Some have reported it but I don't think it is specific to the MO. I think it helps if you keep the air on Refresh or at least limited time on the recirc. Do a search here on the forrum and you will find more information.

I have not had that issue with my MO. Make sure there is a puddle of water under the park MO after using the AC for a period of time. This is normal and is a sign that water is draining correctly from the system. If there isn't any water after using the AC for 20-30 minutes on a typical day your drain line might not be draining correctly hence the odor.
 

·
Premium Member
Joined
·
8,368 Posts
The AC evap drain is probably clogged, and the conditions in the fan/evaporator area make it ripe to grow mold and mildew - which is the source of the odor. First the drain needs to be cleared (you might be able to do this yourself if you can reach it), and the evaporator can be treated with an antifungal treatment (BG Frigifresh comes to mind) to clean out the contamination. This has happened in pretty much every car I've ever driven, including the Murano. However if you catch it early enough, often just unclogging the drain hose is enough to get rid of the smell for quite a while.
 
1 - 3 of 3 Posts
Top