Nissan Murano Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi fellow Murano lovers and experts,

I previously posted a thread on the SES light, Frustrating --> Service Engine Light PROBLEM! , and I finally got an update to this problem. I predicted to be an EVAP leak caused by the gas-cap and the fix would be that the re-programming the computer.

However, this was not the case. The tech guys told me it had some wiring problem?? He wasn't quite specific on the actual problem/fix, but nevertheless, he fixed the problem and the SES light is off now (thank god!).

I am quite curious as to what the problem is, here are the diagnosis codes from the diagnosis report.
1.) FC50AA - RPL EVAP CANISTER VENT CONTROL VALVE
2.) EJ43AA DTC P0442 - EVAP CONTROL SYSTEM
3.) FC9999 - STRAIGHT TIME

It would be great if you guys could explain what these codes mean.

Thanks in advance!
 

·
Premium Member
Joined
·
8,402 Posts
The evap canister is a charcoal canister located adjacent to the gas tank which captures fuel vapors for emissions control. There is a valve which is electrically operated to control the pressure within the canister, and sometimes this valve or the wiring can be damaged or loose. One time I got the same codes on my 97 Maxima after driving in the rain. Turns out the evap canister got a little too wet. I disassembled it, blew it out with compressed air (the valve) and put it back together. Check engine light never came back.
 

·
Registered
Joined
·
466 Posts
Eric L. said:
The evap canister is a charcoal canister located adjacent to the gas tank which captures fuel vapors for emissions control. There is a valve which is electrically operated to control the pressure within the canister, and sometimes this valve or the wiring can be damaged or loose. One time I got the same codes on my 97 Maxima after driving in the rain. Turns out the evap canister got a little too wet. I disassembled it, blew it out with compressed air (the valve) and put it back together. Check engine light never came back.
Thats crazy. I am starting to have all of these little nuisance problems with my MO, and now my friends Altima is having repeated SES lights come on and off in his 02 Altima. I'm starting to wonder why I left the Honda family...:3:
 
1 - 3 of 3 Posts
Top