Nissan Murano Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter #1
Vroooooooom? I went faster but I didn't want to risk anything by taking another picture of going faster...don't want to mess the Mo up now
 

Attachments

·
Registered
Joined
·
4,077 Posts
OMG!!!! :eek: Dude, if you gonna drive fast, don't drive fast and dumb by taking a picture of your speedo while you are driving that fast!!! Dude!!!

CHECK OUT
 

·
Registered
Joined
·
245 Posts
Discussion Starter #3
I know, dude you're insane! Haha, I posted mine before I saw yours..
 

·
Moderator
Joined
·
5,244 Posts
o6murano

just one question: why the pix is so bluuuuuuury.....:D

It should be at least that sharp speedo
 

·
Moderator
Joined
·
5,244 Posts
o6murano said:
My camera on my phone...sorry.
I think it has more to do with hm..........shaky hand:D

Stay safe.:)
 

·
Registered
Joined
·
245 Posts
Discussion Starter #8
I think it has more to do with hm..........shaky hand

Stay safe
Probably, it's a really good cam phone/phone :p sony s710a
 

·
Registered
Joined
·
12,512 Posts
o6murano-

Your MO is brand-new, right? Just a thousand miles or so. Have you ever heard of a break-in period? 100+MPH @ 5,500 RPM is not good for an engine with just 1,000 miles on it.

There are only two conditions where it is acceptable to run a new engine in that manner: 1) it is a rental car, or 2) it is your soon-to-be ex-wife's car. ;) Oops! Sorry, hon.

Be considerate of the VQ. Treat it right when it's young, and it will take care of you for years.

-njjoe
 

·
Registered
Joined
·
263 Posts
Haha...too funny~


Nizmo
 
1 - 11 of 11 Posts
Top